From SmartLiving.ru

Main: Установка компонентов

<<< Назад

Ниже описана процедура подготовки роутера TPLink W703N, однако по аналогии можно настроить любое другое Linux-устройство.

Установка системы

(установка OpenWRT) Образ OpenWRT должен включать веб-сервер, но без веб-панели управления LuCi -- последняя занимает слишком много ценного места на устройстве.

Готовый образ для TPLink W703 можно скачать здесь (пропатченая версия со стабильной работой Arduino через USB)

Подключение к сети

Для подключения к сети необходимо внести изменения в файлы /etc/config/wireless и /etc/config/network

пример настройки беспроводной сети (/etc/config/wireless):

config wifi-device 'radio0'
        option type 'mac80211'
        option channel 'auto'
        option hwmode '11ng'
        option macaddr '16:cd:12:34:86:a0'
        option htmode 'HT20'
        list ht_capab 'SHORT-GI-20'
        list ht_capab 'SHORT-GI-40'
        list ht_capab 'RX-STBC1'
        list ht_capab 'DSSS_CCK-40'
        option disabled '0'

config wifi-iface
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option ssid 'MyHomeNetwork'
        option encryption 'psk'
        option key 'MyPassword'

пример настройки сети (файл /etc/config/network):


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wwan'
        option proto 'dhcp'

После внесения соответствующих правок необходимо перезапустить сеть командой: /etc/init.d/network reload

При правильной настройке данных беспроводной сети, модуль должен получить IP-адрес. Это можно проверить запустив команду ifconfig

Установка необходимых системных компонентов

Для работы модуля нам монадобятся следующие компоненты:

Последовательность команд установки:

opkg update
opkg install bash
opkg install coreutils-stty
opkg install kmod-usb-serial
opkg install kmod-usb-serial-ftdi

Для того чтоб Arduino UNO была добавлена как устройство:

/dev/ttyACM*

Необходимо дополнительно установить компонент:

opkg install kmod-usb-acm

Установка базовых скриптов модуля автоматики

Основные файлы:

/etc/master/cycle.sh -- скрипт основного цикла модуля (должен иметь атрибуты запуска 0755)
/etc/master/socket_client.sh -- скрипт синхронизации СloudSync (должен иметь атрибуты запуска 0755)
/etc/master/settings.sh -- настройки модуля
/etc/master/data/ -- папка данных (сюда будут устанавливаться правила и сохраняться значения переменных)
/www -- папка веб-сервиса
/www/cgi-bin/master -- скрипт веб-сервиса (должен иметь атрибуты запуска 0755)
/www/kraken-master/ -- папка с файлами css-шаблонов веб-интерфейса
/www/menu.html -- веб-интерфейс (файл создаётся/обновляется автоматически при запуске модуля)
/etc/init.d/arduino -- скрипт инициализации модуля (должен иметь атрибуты запуска 0755)
/etc/init.d/cloudsync -- скрипт инициализации CloudSync (должен иметь атрибуты запуска 0755)

Готовый пакет необходимых файлов можно скачать здесь.
Update: особенности установки системы на WirenBoard.

Скопировать переархивированные файлы на роутер.

  scp pack.tar   root@192.168.1.1:/tmp

Зайти на устройство:

  ssh root@192.168.1.1
  cd /tmp

Распаковать

  tar -xf pack.tar /

Посмотреть права доступа и установить, как описано выше (в списке файлов пакета):

  ls -l /www/cgi-bin/
  ls -l /etc/master/

Последовательность настройки:

1. скопировать файлы как обозначено выше
2. выставить атрибуты запуска для нужных файлов
3. Внести изменения в настройки (файл /etc/master/settings.sh) в частности:
MASTER_ID="ABC1-DEF2-GHI3-K5LM" -- уникальный серийный номер устройства (именно в формате четырёх численно-алфавитных порций
ARDUINO_PORT=/dev/ttyACM0 -- порт, к которому подключается Arduino
(на некотрых системах ARDUINO_PORT=/dev/ttyUSB0)
ARDUINO_PORT_SPEED=9600 -- скорость обмена
4. Включить автоматическую загрузку основного цикла командой
/etc/init.d/arduino enable
4.1 (опционально) Включение синхронизации СloudSync
/etc/init.d/cloudsync enable
5. Подключить Arduino, на который загружен необходимый скетч
6. Перезапустить роутер
7. Зарегистрировать устройство на http://connect.smartliving.ru

Опционально: Настройка MQTT

Retrieved from http://majordomo.smartliving.ru/Main/LinuxMiniHubSetup
Page last modified on August 17, 2014, at 09:32 AM EST