Не запускается скетч AMS

Модераторы: Bagir, Ivan, Vit, Alex

Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Не запускается скетч AMS

Сообщение Jake76 » Сб мар 03, 2018 10:24 pm

Друзья, помогите с проблемой: сделал все как в описании, но компиляция выдает это:

dethernet.ino: In function 'void ethernetInit()':
arduino_mega_server:294: error: expected ';' before 'StreamPrint_progmem'
dethernet.ino:13:3: note: in expansion of macro 'Serialprint'
In file included from arduino_mega_server.ino:102:0:
arduino_mega_server:294: error: expected primary-expression before ')' token
dethernet.ino:13:3: note: in expansion of macro 'Serialprint'
arduino_mega_server:294: error: expected ';' before ')' token
dethernet.ino:13:3: note: in expansion of macro 'Serialprint'
dethernet:14: error: 'GATEWAY' was not declared in this scope
Multiple libraries were found for "Ethernet.h"
Used: C:\Users\evgen\Downloads\ams_016\Sketches\Sketches\ams\Arduino\libraries\Ethernet
Not used: C:\Program Files (x86)\Arduino\libraries\Ethernet
expected ';' before 'StreamPrint_progmem'

Что делаю не так?
serghei
Сообщения: 2303
Зарегистрирован: Пт ноя 06, 2015 10:22 am
Откуда: Кишинёв
Благодарил (а): 261 раз
Поблагодарили: 219 раз

Re: Не запускается скетч AMS

Сообщение serghei » Сб мар 03, 2018 10:52 pm

Приветствуем. Но для начала выложите скриншот ,где компилятор кричит об ошибке.
Версия IDE 1.6.5 , 1.8.5 ошибок не выдает , если удалить родную библиотеку Ethernet и вставить из дистрибутива.
AMS : ESP32 + NRF24 + 1Wire-I2C мост DS2482 + счетчик DS2423 + сеть MySensors + редактирование страниц в браузере + Upload по воздуху + SPIFFS
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Сб мар 03, 2018 11:14 pm

библиотеку заменил. Не исправилось. Скрин прилагаю.
Вложения
AMS.jpg
AMS.jpg (291.08 КБ) 1268 просмотров
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Сб мар 03, 2018 11:17 pm

Есть еще сомнения:
на вкладке dethernet
ip заменил на свой, но нужно ли менять мас адрес и Gateway?
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Сб мар 03, 2018 11:18 pm

Да и версию использую 1.6.5
serghei
Сообщения: 2303
Зарегистрирован: Пт ноя 06, 2015 10:22 am
Откуда: Кишинёв
Благодарил (а): 261 раз
Поблагодарили: 219 раз

Re: Не запускается скетч AMS

Сообщение serghei » Сб мар 03, 2018 11:23 pm

Хмм.... Чудес не бывает. В дистрибутиве ничего не меняли ? Если не получится скомпилировать , то завтра вечером дайте доступ по вьюверу.
IP и Gateway надо менять на свой. Мак адрес менять не надо. Для синхронизации времени надо в некоторых случаях добавить DNS ( он закомментирован).
AMS : ESP32 + NRF24 + 1Wire-I2C мост DS2482 + счетчик DS2423 + сеть MySensors + редактирование страниц в браузере + Upload по воздуху + SPIFFS
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Сб мар 03, 2018 11:36 pm

Ок. Спасибо! Сегодня еще повожусь. Попробую сделать все заново. Если не получится - буду очень благодарен за вашу помощь завтра вечером!
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Вс мар 04, 2018 2:26 am

Большое вам спасибо! Продвинулся вперед немного :) Убил IDE, библиотеки, папку temp, установил все с нуля и пошло. Видимо где-то что-то мешало. Далее разобрался с отображением иероглифов в мониторе порта (в скетче стояло 115200бод, а в IDE по умолчанию 9600): выставил 115200 в мониторе и иероглифы пропали.
Но теперь столкнулся с другой проблемой - скетч не видит SD карту. Если не получится победить - напишу.
serghei
Сообщения: 2303
Зарегистрирован: Пт ноя 06, 2015 10:22 am
Откуда: Кишинёв
Благодарил (а): 261 раз
Поблагодарили: 219 раз

Re: Не запускается скетч AMS

Сообщение serghei » Вс мар 04, 2018 10:03 am

Отлично , что дело сдвинулось с мертвой точки. Но пойдет еще быстрее, если Вы будете наглядно показывать хотябы лог старта AMS. В скетче ошибок нет. А карта не видится по двум причинам - она битая или скетч не видит партиции , о чем не двусмысленно сообщает в сериале. Файлы закинули без каталогов , прямо в корень ? Лог старта в студию , пожалуйста.

С телефона сложно комментировать, вечером из дома проще будет.

Как пример - CD карту видит , а портиции нет. Лечил карту очень долго , какой то внешней прогой низко уровневого форматирования.
  • Modul SD...
    SD init... OK
    index.htm... found
    Check..............
    Files: 143
    Size: 1973879
    started
    Modul SD Info...
    SD type: SDHC
    Not find partition
AMS : ESP32 + NRF24 + 1Wire-I2C мост DS2482 + счетчик DS2423 + сеть MySensors + редактирование страниц в браузере + Upload по воздуху + SPIFFS
Jake76
Сообщения: 8
Зарегистрирован: Сб мар 03, 2018 10:20 pm
Благодарил (а): 0
Поблагодарили: 0

Re: Не запускается скетч AMS

Сообщение Jake76 » Вс мар 04, 2018 1:44 pm

Как понимаю, у меня тот вариант, что "битая" карта по логам, верно?
Но я пробовал 2 карты, разные, да - не новые. Но форматировал вчера их даже прогой SD_CardFormatter - все бесполезно. Что ж за беда с картами? нужно пойти в магазин купить штук 5 разных и то не будет гарантии, что считаются...
Вложения
AMS1.png
AMS1.png (62 КБ) 1177 просмотров
Ответить